SpringBoot 2.5.0 For Jackson Kotlin classes support please add “com.fasterxml.jackson.module: jackson-module-kotlin” to the classpath

Total
1
Shares

Small question about a warning I am receiving please.

After the release of 2.5.0 of SpringBoot, I just did a version bump from 2.4.x to 2.5.0, without any code change.

Suddenly, on application start up, I am getting

kground-preinit] o.s.h.c.j.Jackson2ObjectMapperBuilder: For Jackson Kotlin classes support please add "com.fasterxml.jackson.module:jackson-module-kotlin" to the classpath

The thing is, my Springboot all is not a Kotlin app, it is a Java app.

It has nothing Kotlin.

Furthermore, I am not even doing any explicit JSON parsing.

May I ask how I can disable, resolve this warning please?


Solution

There seems to be a solution here. The idea is to provide extra configuration for Jackson2ObjectMapperBuilderCustomizer. Sucks that a code change is required but there you have it.

Leave a Reply

Your email address will not be published. Required fields are marked *